summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorInfernio2020-10-10 16:32:58 +0200
committerInfernio2020-10-10 16:50:10 +0200
commit2434929f3ecfbca5d48c4522683fc5bd4d1d1001 (patch)
tree843ab1f55012730a42680bab21664c94af7f73fd /PKGBUILD
parent18401aa63779bc970fe50b626726fce90be8312f (diff)
downloadaur-python2-lz4.tar.gz
Initial commit
Based on official python-lz4 sources pre-py2 removal
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 32 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4bcfc46a267..bf7718cb113d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,37 @@
-# Submitter: Vladimir Tsanev <tsachev@gmail.com>
-# Previous Maintainer: Andrew Reed <reed.996@osu.edu>
-# Maintainer: "Score_Under" <seejay.11@gmail.com>
+# Maintainer: Infernio <infernio at icloud dot com>
+# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: Nissar Chababy <funilrys at outlook dot com>
+# Contributor: Thrasibule <guillaume dot horel at gmail dot com>
+# Contributor: David Manouchehri <manouchehri@riseup.net>
+# Contributor: Vladimir Tsanev <tsachev@gmail.com>
+# Contributor: Andrew Reed <reed.996@osu.edu>
+# Contributor: "Score_Under" <seejay.11@gmail.com>
+
pkgname=python2-lz4
-pkgver=0.10.1
-pkgrel=1
-pkgdesc="LZ4 Bindings for Python"
-arch=('any')
-url="https://github.com/steeve/python-lz4"
+_pkgname=lz4
+pkgver=2.2.1
+pkgrel=4
+pkgdesc="LZ4 bindings for Python 2"
+arch=('x86_64')
license=('BSD')
-makedepends=('python2-distribute')
-depends=('python2')
-source=("https://pypi.python.org/packages/f5/c6/ef2890b5e287735576e15c1389aa0b9032c9d78ed72385fbd1149af593cd/lz4-$pkgver.tar.gz")
-md5sums=('1b8de6217e0785e92f457056c053e058') # Officially provided
-sha256sums=('a0423290a6e89c1789525a7e9d344d877c7a97102cf5c0f99b2319ac560f1b3e')
+url="https://github.com/python-lz4/python-lz4"
+depends=('python2' 'python2-future')
+makedepends=('python2-setuptools-scm' 'python2-pkgconfig')
+checkdepends=('python2-pytest' 'python2-psutil')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-${pkgver}.tar.gz")
+sha512sums=('3f6400c0ac02182306fcb0e76fc78fdcec604bd89baa288c71261cce05350de244eb0d4263e4c1c1d647a529426beac409b3ff20c170c3ea19c7dd82cfae834b')
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ python2 -m pytest
+}
package() {
- cd $srcdir/lz4-$pkgver
- python2 setup.py install --root=$pkgdir || return 1
+ cd $_pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
}