summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-11-14 20:21:12 +0100
committerhaawda2017-11-14 20:21:12 +0100
commit78c9dd8052888b9a2106feac9253dc7e350a48bb (patch)
tree61ef91ad304de48ef9b394003d494eee8c5d236d /PKGBUILD
parent10c927910f1a1db27ff87496411202e6bccb326f (diff)
downloadaur-python2-meep.tar.gz
adopted and beautified
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 530141cffcdd..4a7e5aab9034 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
-# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+# Contributor: Lucas H. Gabrielli <heitzmann@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=python2-meep
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Python binding for MEEP (FDTD solver by MIT)"
url="https://launchpad.net/python-meep"
arch=('x86_64' 'i686')
license=('GPL')
depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-matplotlib' 'meep' 'openmpi' 'swig')
-makedepends=()
-conflicts=()
-replaces=()
-backup=()
-install=
source=("https://launchpad.net/python-meep/1.4/1.4/+download/python-meep-${pkgver}.tar")
md5sums=('f8913542d18b0dda92ebc64f0a10ce56')
build() {
- cd "${srcdir}/python-meep"
+ cd python-meep
tail -n +3 meep-site-init.py.standard > meep-site-init.py
python2 setup-mpi.py clean --all
python2 setup-mpi.py build_ext
}
package() {
- cd "${srcdir}/python-meep"
+ cd python-meep
python2 setup-mpi.py install --prefix=/usr --root=${pkgdir}
}
-
-# vim:set ts=2 sw=2 et: