summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTruocolo2024-01-31 15:31:58 +0100
committerTruocolo2024-01-31 15:31:58 +0100
commit708cc0c1a73e6041be9a6d8e19cf4690d9a1aeec (patch)
treeb56c7982916fb9540619ed78767acb7df3e60b6e /PKGBUILD
parenta947859d05e167f704d90e42f1137cc45be1b10e (diff)
downloadaur-python2-monotonic.tar.gz
add license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 42 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc12158f420f..879be84b1be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,58 @@
+# SPDX-License-Identifier: AGPL-3.0
+#
+# Maintainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Maintainer: Truocolo <truocolo@aol.com>
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Daniel Peukert <daniel@peukert.cc>
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Kevin Houdebert <kevin@qwazerty.eu>
# Contributor: Erhan SAHIN <erhan@ssahin.net>
-pkgname='python2-monotonic'
-_name="${pkgname#python2-}"
+_py='python2'
+_pkg='monotonic'
+pkgname="${_py}-monotonic"
pkgver=1.6
pkgrel=2
-pkgdesc='An implementation of time.monotonic() (legacy Python 2 version)'
+_pkgdesc=(
+ 'An implementation of time.monotonic()'
+ '(legacy Python 2 version)'
+)
+pkgdesc="${_pkgdesc[*]}"
arch=('any')
-url="https://pypi.org/project/${_name}/${pkgver}/"
+url="https://pypi.org/project/${_pkg}/${pkgver}/"
license=('Apache')
-depends=('python2')
-makedepends=('python2-setuptools')
-_tarname="${_name}-${pkgver}"
-source=("${_tarname}.tar.gz::https://github.com/atdt/${_name}/archive/${pkgver}.tar.gz")
-sha256sums=('9609c249aed584fd714811014870650d08d6f6414402b5a190663c49bf83b221')
+depends=(
+ 'python2'
+)
+makedepends=(
+ 'python2-setuptools'
+)
+_tar="${_pkg}-${pkgver}"
+_url="https://github.com/atdt/${_pkg}"
+source=(
+ "${_tar}.tar.gz::${_url}/archive/${pkgver}.tar.gz"
+)
+sha256sums=(
+ '9609c249aed584fd714811014870650d08d6f6414402b5a190663c49bf83b221'
+)
build() {
- cd "${_tarname}"
- python2 setup.py build
+ cd \
+ "${_tar}"
+ "${_py}" \
+ setup.py \
+ build
}
package() {
- cd "${_tarname}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ cd \
+ "${_tar}"
+ "${_py}" \
+ setup.py \
+ install \
+ --root="${pkgdir}" \
+ --optimize=1 \
+ --skip-build
}
+
+# vim:set sw=2 sts=-1 et: