summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-07-03 02:02:31 +0300
committerErhan SAHIN2015-07-03 02:02:31 +0300
commited80b043f01b7f5a7eb9fb7d7597783ed2584fb3 (patch)
tree54244287abf790cde3b321f2f4fe1a18f219531e /PKGBUILD
downloadaur-python2-oslo-config-liberty.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a03d1ed6a32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Erhan SAHIN < erhan@ssahin.net >
+
+pkgname=('python2-oslo-config-liberty')
+pkgver=1.12.1
+pkgrel=1
+pkgdesc="parsing command line arguments and .ini style configuration files"
+arch=('any')
+url="https://pypi.python.org/pypi/oslo.config/1.12.1"
+license=('GPL')
+provides=("python2-oslo-config")
+makedepends=('python2-setuptools' 'python2')
+source=("https://pypi.python.org/packages/source/o/oslo.config/oslo.config-$pkgver.tar.gz")
+md5sums=('b20e00b2a5ec129a3b58d84308f381ae')
+
+build() {
+ cd "$srcdir/oslo.config-$pkgver"
+ python2 setup.py build
+ echo ${pkgver} > versioninfo
+}
+
+package_python2-oslo-config-liberty() {
+
+ depends=('python2' 'python2-setuptools')
+
+ cd "$srcdir/oslo.config-$pkgver"
+ python2 setup.py install --root=${pkgdir}
+}