summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-07-03 02:07:05 +0300
committerErhan SAHIN2015-07-03 02:07:05 +0300
commit628e8573f04c0ae1dfe90cca70c955a746c9c51a (patch)
tree9baad6aa2c08ee6e01950e1768b4a1b1bc7d0ad1 /PKGBUILD
downloadaur-python2-oslo-policy-liberty.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..854032994e51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Erhan SAHIN < erhan@ssahin.net >
+
+pkgname="python2-oslo-policy-liberty"
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Oslo Policy"
+arch=("any")
+url="https://pypi.python.org/pypi/oslo.policy"
+license=("Apache")
+provides=("python2-oslo-policy")
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/o/oslo.policy/oslo.policy-${pkgver}.tar.gz")
+sha256sums=('49fd7746ad87253112673178050083fa66e78b51a4f9a063b4366f9d0c6a4df8')
+
+build() {
+ cd "${srcdir}/oslo.policy-${pkgver}/"
+ python2 setup.py build
+}
+
+package_python2-oslo-policy-liberty() {
+ depends=('python2-oslo-config-liberty'
+ 'python2-oslo-i18n-liberty'
+ 'python2-oslo-serialization-liberty')
+ cd "${srcdir}/oslo.policy-${pkgver}/"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}