summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-07-03 02:07:38 +0300
committerErhan SAHIN2015-07-03 02:07:38 +0300
commitc85745238abc0c16b2e889a9decedddfa6e2b835 (patch)
tree9ca7255997d477e0f82cf9cf38e2373482281253 /PKGBUILD
downloadaur-python2-oslo-rootwrap-liberty.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19ab7b7e05f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname="python2-oslo-rootwrap-liberty"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Oslo rootwrap - A root escalation wrapper for OpenStack"
+arch=("i686" "x86_64")
+url="https://pypi.python.org/pypi/oslo.rootwrap/"
+license=("Apache")
+
+depends=("python2"
+ "python2-six")
+
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/o/oslo.rootwrap/oslo.rootwrap-${pkgver}.tar.gz")
+md5sums=('1cd1ac826d29fdd1da9a030127e97034')
+
+build() {
+ cd "${srcdir}/oslo.rootwrap-${pkgver}/"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/oslo.rootwrap-${pkgver}/"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}