summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-06-11 23:22:20 +0300
committerErhan SAHIN2015-06-11 23:22:20 +0300
commit32999e13381b13535e064853783c4ba51ddb75ca (patch)
tree042ba11d1f603910cd9545028e989f718e15968d /PKGBUILD
downloadaur-python2-oslosphinx-kilo.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8bd9165a020
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=("python2-oslosphinx-kilo")
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="OpenStack Sphinx Extensions and Theme"
+arch=(any)
+url="https://pypi.python.org/pypi/oslosphinx"
+license=('Apache')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/source/o/oslosphinx/oslosphinx-$pkgver.tar.gz")
+md5sums=('2548a1da0c24853c4758eb314530d830')
+
+build() {
+ cd "${srcdir}/oslosphinx-${pkgver}/"
+ python2 setup.py build
+}
+
+package() {
+ depends=('python2')
+
+ cd "${srcdir}/oslosphinx-${pkgver}/"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
+