summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2017-01-24 09:40:35 -0500
committerXavierCLL2017-01-24 09:40:35 -0500
commitc850b30c63ecbe440a5626271f8c3b89e7eafddc (patch)
tree5bb27b160318cbb2ca0d6707346f849d87db2c1b /PKGBUILD
parenta1d047ef8e1f22939bec3c9d69f18ea69b8fc8db (diff)
downloadaur-python2-poppler-qt4.tar.gz
Fix new sip version, thanks jarylc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71968bc474b8..908447cd1d52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: Philip Lorenz <lorenzph@users.sourceforge.net>
+# Maintainer: XavierCLL
pkgname=python2-poppler-qt4
_realpkgname=python-poppler-qt4
pkgver=0.24.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Python 2 binding to poppler-qt"
arch=('i686' 'x86_64')
url="https://github.com/wbsoft/python-poppler-qt4"
license=('LGPL')
depends=('python2-pyqt4' 'poppler-qt4' 'python2')
-source=(https://github.com/wbsoft/$_realpkgname/archive/v$pkgver.tar.gz)
+#source=(https://github.com/wbsoft/$_realpkgname/archive/v$pkgver.tar.gz)
+source=(https://github.com/zehome/python-poppler-qt4/archive/46fd6a237aefe33a18edee601e548a33ba6f2a50.zip)
conflicts=('python2-poppler-qt<=0.24.0')
-md5sums=('c6d4a1038329350ca01704e7c2613f4f')
+md5sums=('c60622ddc4e2a379a3ae8950e05128bd')
_build_ext_args="--qmake-bin=/usr/bin/qmake-qt4"
build() {
- cd "$srcdir/$_realpkgname-$pkgver"
+ cd $srcdir/$_realpkgname-*
python2 setup.py build_ext ${_build_ext_args}
}
package() {
- cd "$srcdir/$_realpkgname-$pkgver"
+ cd $srcdir/$_realpkgname-*
python2 setup.py install --root="${pkgdir}" \
build_ext ${_build_ext_args}