summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRenze Nicolai2016-10-24 02:44:10 +0200
committerRenze Nicolai2016-10-24 02:44:10 +0200
commitcef3666060252a600fbc50b0bc2032d2521699fc (patch)
tree3d98207ec281eb7e540ab58f49ad3f29832156d6 /PKGBUILD
downloadaur-python2-pubsub-git.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7996d846f2ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Renze Nicolai <renze@rnplus.nl>
+# Builds from GIT repository by user "schollii"
+
+pkgname=python2-pubsub-git
+gitname=pypubsub
+pkgver=20161021.0a0e49c
+pkgver() {
+ cd "$gitname"
+ git log -1 --format=%cd.%h --date=short|tr -d -
+ #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgrel=1
+pkgdesc="Python Publish-Subscribe Package"
+arch=('any')
+url="https://pypi.python.org/pypi/PyPubSub"
+license=('BSD')
+depends=("python2")
+makedepends=("python2-setuptools")
+source=("git+https://github.com/schollii/pypubsub.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$gitname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$gitname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}