summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLingMan2021-06-30 21:40:26 +0200
committerLingMan2021-06-30 21:43:37 +0200
commit728a176311ca82b563b3dc62ba66e4ed0c8e8d24 (patch)
treea0fba42c8c4e100a1f9c505f7048a560a3560d02 /PKGBUILD
downloadaur-python2-pyhamcrest.tar.gz
AUR submission after python2 support was dropped from the main repos in
https://github.com/archlinux/svntogit-community/commit/0246d2a959a9932e73799efa32dfc1f058703f7c
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2de2b9974909
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+pkgname=python2-pyhamcrest
+# Do not update. 1.10.1 is the last version supporting Python2
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="Hamcrest framework for matcher objects (1.10.x is the last version supporting Python 2)"
+arch=('any')
+license=('BSD')
+url="https://github.com/hamcrest/PyHamcrest"
+depends=('python2-six')
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tgz::https://github.com/hamcrest/PyHamcrest/archive/refs/tags/V$pkgver.tar.gz")
+sha512sums=('f7e79f7d26c4c6add042052e451898bbf5adf21b05a234cc62bce890d68f5997693b042a9daf136f7026040a8ab7bf28b829288417b947973dcb959bf613a37b')
+
+build() {
+ cd PyHamcrest-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd PyHamcrest-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+}