summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2017-03-14 12:42:11 +0000
committerGrey Christoforo2017-03-14 12:42:11 +0000
commit7e59334bc6784a4a2a1dad9c9808fa4829fd1f51 (patch)
tree279055bb90205899cb0a0bf4fbdef638b4b361fb /PKGBUILD
downloadaur-python2-pyina.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeb42c0d5765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=('python2-pyina')
+_module='pyina'
+pkgver='0.1a1'
+pkgrel=1
+pkgdesc="MPI parallel map and cluster scheduling"
+url="http://www.cacr.caltech.edu/~mmckerns/pyina.htm"
+depends=('python2' 'python2-dill' 'python2-mpi4py')
+#optdepends=('python2-pyre')
+makedepends=('python2-setuptools')
+provides=('python2-pyina')
+conflics=('python2-pyina-git')
+license=('BSD')
+arch=('any')
+
+source=("https://files.pythonhosted.org/packages/source/p/pyina/pyina-${pkgver}.tgz")
+md5sums=('e6c3c09d6b86f0a47246348680e35fbf')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}