summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVinicius Correa2018-03-20 15:05:00 -0300
committerVinicius Correa2018-03-20 15:05:00 -0300
commit186a0bb4e53cea0ed69480b859ffdf48049d6a6b (patch)
tree4004547b3cbd441f34788c949e84b7406582158f /PKGBUILD
downloadaur-python2-pykcs11.tar.gz
my first package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4d4fd0b3e88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+_pkgname=PyKCS11
+pkgname=python2-pykcs11
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="PKCS#11 wrapper for Python."
+arch=('any')
+url="https://github.com/LudovicRousseau/${_pkgname}"
+license=('GPL')
+depends=('python2' 'swig')
+makedepends=('git')
+optdepends=()
+conflicts=()
+source=("https://github.com/LudovicRousseau/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('dc5fdeeb92eeee7125eb418a523c59f8')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}