summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:09:16 +0200
committerAlexander F Rødseth2015-06-10 15:09:16 +0200
commit6e9706ee5bcf236a2be4f839a176c1df199233ac (patch)
tree5b3436193d8ee7daa29be52b5b5021f60e4f0048 /PKGBUILD
downloadaur-python2-pylearn2.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c03d28da9535
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=python2-pylearn2
+pkgver=0.1
+pkgrel=1
+pkgdesc='Machine learning library based on Theano'
+arch=('any')
+url='http://github.com/lisa-lab/pylearn2'
+license=('GPL')
+depends=('python2-theano')
+source=("git://github.com/lisa-lab/pylearn2.git")
+md5sums=('SKIP')
+
+build() {
+ cd pylearn2
+
+ python2 setup.py build
+}
+
+package() {
+ cd pylearn2
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: