summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:38:15 -0300
committerBruno Galeotti2015-06-08 15:38:15 -0300
commit36c4408699b476bc8e9b4dbc2b343f6fbc2f6d61 (patch)
treea3d75c7db1caa63118003313c4f7d085d9b9e853 /PKGBUILD
downloadaur-python2-pysswords.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f3e565cd8c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Bruno Galeotti <bgaleotti at gmail dot com>
+
+pkgname=python2-pysswords
+pkgver=0.0.12
+pkgrel=1
+pkgdesc="Pysswords manages encrypted login credentials in a local database"
+arch=(any)
+url="https://github.com/marcwebbie/pysswords"
+depends=('python2' 'python2-colorama' 'python2-gnupg-patched' 'python2-tabulate' 'python2-pyperclip' 'python2-yaml')
+source=("https://pypi.python.org/packages/source/p/pysswords/pysswords-$pkgver.tar.gz")
+
+
+build() {
+ cd "$srcdir/pysswords-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/pysswords-$pkgver"
+ python2 setup.py install --root=$pkgdir --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('d7f714b9086594d2d14820fa4990d653')