summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Forencich2015-07-20 11:54:33 -0700
committerAlex Forencich2015-07-20 11:54:33 -0700
commit757789bbf1e518ad175964b4c04515283820dd76 (patch)
treeb30051dbd21bfa76b193830d35b4c80e22efb3eb /PKGBUILD
downloadaur-python2-pyusb-git.tar.gz
Inital import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea633425e4c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alex Forencich <alex@alexforencich.com>
+pkgname=python2-pyusb-git
+pkgver=1.0.0b2.r52.g39816be
+pkgrel=1
+pkgdesc="Easy USB access from Python"
+arch=('any')
+url="http://sourceforge.net/apps/trac/pyusb/"
+license=('BSD')
+depends=('python2' 'libusb')
+makedepends=('git')
+provides=('python2-pyusb')
+
+_gitroot='https://github.com/walac/pyusb'
+_gitname='pyusb'
+
+source=("$_gitname::git+$_gitroot")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+