summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJimmy Brisson2016-04-19 22:07:52 -0500
committerJimmy Brisson2016-04-19 22:07:52 -0500
commit2a4b8b2925d719705e776a8be5bd22d98a935289 (patch)
tree16622606265cd61bac49425efbffde552e7b7e69 /PKGBUILD
parent5776a5cad728f2e643c61ea0d93661eedf15d197 (diff)
downloadaur-python2-qtlc3-git.tar.gz
added help and missing deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0982c8a9282..9a2dd949203d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jimmy Brisson <theotherjimmy@gmail.com>
pkgname=python2-qtlc3-git
-pkgrel=1
+pkgrel=2
pkgver=r119.25b0d84
pkgdesc="A python and C++ LC-3 simulator frontend in QT"
arch=('any')
url="http://github.com/theotherjimmy/pylc3"
license=('GPL')
depends=('boost' 'boost-libs' 'python2' 'qt4' 'python2-pylc3-git')
-makedepends=('git' 'boost' 'boost-libs' 'python2' 'qt4' 'python2-pylc3-git')
+makedepends=('git' 'boost' 'boost-libs' 'python2' 'qt4' 'python2-pylc3-git' 'qt5-base' 'qtchooser')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname}::git+https://github.com/mbartling/QtLC3.git")
@@ -29,4 +29,6 @@ package() {
cd "$srcdir/${pkgname%-VCS}"
mkdir -p ${pkgdir}/usr/bin
install LC3Sim ${pkgdir}/usr/bin/qtlc3
+ mkdir -p ${pkgdir}/usr/bin/help
+ cp -r help ${pkgdir}/usr/bin/help
}