summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2015-12-14 14:40:56 +0100
committerCedric Girard2015-12-14 14:40:56 +0100
commitff5380ca0564f5718c5563b0ab7eee895dcc8835 (patch)
tree2c74d0fb98cd87c8c8a36489e472deaffc3ece01 /PKGBUILD
downloadaur-python2-rednose.tar.gz
first package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0bc0cbed4e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+_pythonmod=rednose
+pkgname=python2-rednose
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="coloured output for nosetests"
+arch=('any')
+url="http://pypi.python.org/pypi/${_pythonmod}"
+license=('MIT')
+depends=('python2' 'python2-colorama' 'python2-termstyle')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
+md5sums=('0f4d5ff44fc0f64cb5ed5b57f3605f64')
+
+build() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python2 setup.py build
+ }
+
+package() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python2 setup.py install --root=${pkgdir}
+}