summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:44:17 -0400
committerFrançois Boulogne2015-06-09 21:44:17 -0400
commit515e6a3f5d5d8f8432df62fbb9dd16d0bea6ee80 (patch)
tree93f92c3bc3fd66df19037f72efc0191cad7220b7 /PKGBUILD
downloadaur-python2-requesocks.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa20ce352376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Francois Boulogne <fboulogne at april dot org>
+
+pkgname=python2-requesocks
+pkgver=0.10.8
+pkgrel=1
+pkgdesc="Python HTTP for Humans, with socks proxy support"
+arch=('any')
+url="https://pypi.python.org/pypi/requesocks"
+license=('ISC')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=(https://pypi.python.org/packages/source/r/requesocks/requesocks-$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/requesocks-$pkgver"
+ python2 setup.py build
+}
+
+package(){
+ cd "$srcdir/requesocks-$pkgver"
+ python2 setup.py install --root="${pkgdir}"
+}
+
+# vim:ts=2:sw=2:et:
+md5sums=('3f43bd8a00c704b3de4f1a212cc72818')