summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDJ Lucas2015-12-07 18:24:38 -0600
committerDJ Lucas2015-12-07 18:24:38 -0600
commit1f34c302304a1a06490e8b555da6c2fab9c9f96f (patch)
treef0999f2eb40b16a521c81a60d23698ec540266db /PKGBUILD
parentd32fb786a72aa0c09e79d1c7cbcb7f363ed06e89 (diff)
downloadaur-python2-rpclib.tar.gz
Use python2, fix perms
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1787e52d499..3a3cdbc19cc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=python2-rpclib
_pkgname=rpclib
pkgver=2.8.0
-pkgrel=2
+pkgrel=3
pkgdesc="A transport and architecture agnostic rpc (de)serialization library that focuses on making small, rpc-oriented messaging work"
arch=('any')
url="http://github.com/arskom/rpclib"
license=('LGPL')
depends=('python2-pytz' 'python2-lxml')
-optdepends=('mod_wsgi')
+optdepends=('mod_wsgi2')
source=(https://pypi.python.org/packages/source/r/${_pkgname}/${_pkgname}-${pkgver}-rc.tar.gz)
sha256sums=('846d46bc6ffff23a3c8382df45dce5ac2e7d889ce1904d2b394864d21cf329c1')
@@ -24,4 +24,5 @@ build() {
package() {
cd ${srcdir}/${_pkgname}-${pkgver}-rc
python2 setup.py install --root=${pkgdir}/
+ chmod 664 ${pkgdir}/usr/lib/python2.7/site-packages/rpclib-2.8.0rc0-py2.7.egg-info/*
}