summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrançois Boulogne2015-06-09 21:38:02 -0400
committerFrançois Boulogne2015-06-09 21:38:02 -0400
commitdab150c7e7ffc54c2fe9e005482ceb88cea7ec25 (patch)
tree93058c881550c9779a0c5d2b2ec2a739caf32346 /PKGBUILD
downloadaur-python2-skypipe-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01b207e93f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Christophe-Marie Duquesne <chm.duquesne@gmail.com>
+
+pkgname=python2-skypipe-git
+pkgver=20120901
+pkgrel=1
+pkgdesc="netcat through dotcoud"
+arch=(any)
+url="https://github.com/progrium/skypipe"
+license=('MIT')
+depends=('python2' 'python2-colorama' 'python2-pyzmq-static'
+ 'python2-requests')
+makedepends=('git')
+provides=('skypipe')
+conflicts=('skypipe')
+
+_gitroot="https://github.com/progrium/skypipe.git"
+_gitname="skypipe"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server..."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "Running the install script..."
+ cd "$srcdir/$_gitname"
+ ls
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}