summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-08-17 09:20:46 +0300
committerAchilleas Pipinellis2015-08-17 09:25:48 +0300
commitf1415913ffd3d920a257036114bd7f6b24b9bb1c (patch)
tree978c0b05d9eedc15e224ceb81f2098735263507d /PKGBUILD
parenta961d10a5d38a475608c949cdd1d0095e1735836 (diff)
downloadaur-python2-smartypants.tar.gz
Prevent conflict with python-smartypants
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5d0d5b07f76..2ff1940739da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python2-smartypants
_pkgname=smartypants
pkgver=1.8.6
-pkgrel=1
+pkgrel=2
pkgdesc="A smart-quotes plugin"
url="http://web.chad.org/projects/smartypants.py/"
arch=('any')
@@ -23,5 +23,8 @@ package()
sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' setup.py
sed -i 's|#!/usr/bin/python|#!/usr/bin/env python2|' smartypants{.py,}
python2 setup.py install --root="${pkgdir}" -O1
+
+ # Prevent conflict with python-smartypants
+ mv "${pkgdir}/usr/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}2"
}
md5sums=('97484a618fc35508ca2961445f4aa597')