summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2019-06-09 22:21:59 +0800
committerUniversebenzene2019-06-09 22:21:59 +0800
commit7a4b2212eb9292bc5ba5a311f997adf88255b276 (patch)
treea5df5383c6e3d7f5ac4627d20786c1cf526181a3 /PKGBUILD
downloadaur-python2-sncosmo-doc.tar.gz
Initial import 1.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a715a1e9e781
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=sncosmo
+pkgname=python2-${_pyname}-doc
+pkgver=1.8.2
+pkgrel=1
+pkgdesc="Documentation for SNCosmo"
+arch=('i686' 'x86_64')
+url="https://sncosmo.readthedocs.io/"
+license=('BSD')
+makedepends=("python2-${_pyname}=${pkgver}" 'python2-sphinx_rtd_theme' 'python2-sphinx-gallery' 'python2-iminuit' 'python2-numpydoc')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('3b18d131d1e254b729a978a1a2f0fa38')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ make SPHINXBUILD=sphinx-build2 html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}