summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNiklas2017-08-05 01:35:55 +0200
committerNiklas2017-08-05 01:35:55 +0200
commit0191a058b0435119898f192e9234cae98f2f86ed (patch)
treed86e9461bf57b813edf89b06ae3650dcdd1c609b /PKGBUILD
downloadaur-python2-sockjs-tornado.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a4ce5fb6706
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Niklas <dev@n1klas.net>
+# Contributor: David McInnis <davidm@eagles.ewu.edu>
+
+pkgname='python2-sockjs-tornado'
+_module='sockjs-tornado'
+pkgver='1.0.3'
+pkgrel=1
+pkgdesc="SockJS python server implementation on top of Tornado framework"
+url="http://github.com/mrjoes/sockjs-tornado/"
+depends=('python2' 'python2-tornado')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz")
+sha256sums=('6d726e61bd1d884bd1c1788727fce1b9f24fd69062dda0daf61a476b01718e99')
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}