summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Rodrigues2018-01-20 19:03:13 +0000
committerHugo Rodrigues2018-01-20 19:03:13 +0000
commit5d953a58dbf2a102604f91fed2a1c40e9aca89ab (patch)
treeefc85b75c18fe1ea57aac8e7102458fbcf53b802 /PKGBUILD
downloadaur-python2-sparkpost.tar.gz
Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dd46054b3e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Hugo Rodrigues <me@hugorodrigues.net>
+_pipname=sparkpost
+pkgname=python2-${_pipname}
+pkgver=1.3.5
+pkgrel=1
+pkgdesc="SparkPost client library for Python2"
+arch=("any")
+url="https://github.com/SparkPost/python-sparkpost"
+license=("Apache")
+depends=("python2")
+makedepends=("python2-pip")
+
+build() {
+ pip2 install --no-deps --target="${_pipname}" ${_pipname}==${pkgver}
+}
+
+package() {
+ mkdir -p $pkgdir/usr/lib/python2.7/site-packages/
+ cp -r $srcdir/${_pipname}/* $pkgdir/usr/lib/python2.7/site-packages/
+}
+