summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaze X2017-03-01 10:49:08 +0100
committerMaze X2017-03-01 10:49:08 +0100
commit970bda7d908c5687c542ea8ddeb774faef9a6e47 (patch)
treeef6181b91b8bd09b2b74048f0678d2ddce15a1b0 /PKGBUILD
downloadaur-python2-sqlitedict.tar.gz
New package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f5d1d8e1981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Wijnand Modderman-Lenstra <maze@pyth0n.org>
+pkgname=python2-sqlitedict
+_pkgname=sqlitedict
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Persistent dict in Python, backed up by sqlite3 and pickle, multithread-safe"
+arch=(i686 x86_64)
+url="https://github.com/piskvorky/sqlitedict"
+license=('MIT')
+groups=()
+depends=('python2')
+makedepends=('python2-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+_hash=7e/ab/e8af7777c1b7daafc9b7594dc17872b72d64cc8524ecd4e7c1f261918e72
+source=(https://pypi.python.org/packages/$_hash/$_pkgname-$pkgver.tar.gz)
+sha256sums=('76ea12115d3961e2aea2f277a785ac9df3d463d50cc0b02afdcf1ea6ec833f94')
+sha512sums=('87c9601b71e93a907b27d4b93f0a7a8e08a07de226cb6f9af158feb93ddd6a96109251d9e5205a47cd38bde919fd33eecadbce2966783a97902a9a1e1cd18c60')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: