summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-03-24 19:27:15 +0900
committerBenjamin Chrétien2016-03-24 19:27:15 +0900
commit41fdd2a5688ef5b6c83a3bc54b49509331ef69e2 (patch)
tree30a830e373587bea81007a6e6c253b5ca8df132d /PKGBUILD
downloadaur-python2-stl.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c81f731d64a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Automatically generated by pip2arch on 2016-03-24
+
+pkgname=python2-stl
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Read and write STL 3D geometry files in both the ASCII and the binary flavor"
+url="UNKNOWN"
+depends=('python2' )
+makedepends=('python2-distribute' )
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/s/stl/stl-${pkgver}.tar.gz")
+sha256sums=('03a6b58ad52ecf16823b1cf1acf6ef382aa5c0fc1152379f464e284a4f81304b')
+
+build() {
+ cd "${srcdir}/stl-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/stl-${pkgver}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}