summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Schumacher2021-01-23 11:59:45 +0100
committerTim Schumacher2021-01-23 11:59:45 +0100
commit3e7edf9ea052da4cb16a5debb2f43c54292a7bd7 (patch)
tree3e06e3f0ae53654fe13ea53c65b45f9a8e5009f0 /PKGBUILD
downloadaur-python2-titlecase.tar.gz
Initial python2-titlecase package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d9c2745cf37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=python2-titlecase
+_module='titlecase'
+pkgver=0.13.1
+pkgrel=1
+pkgdesc="Python Port of John Gruber's titlecase.pl (old version with python2 support)"
+url="https://github.com/ppannuto/python-titlecase"
+depends=('python2' 'python2-nose' 'python2-regex')
+makedepends=('python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/t/titlecase/titlecase-${pkgver}.tar.gz")
+sha256sums=('5b34bea05a2b9dac22abc1455f23416b8f5f971d664b77230328dbaab5556f3d')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ # Avoid conflicts with the Python 3 package
+ mv "${pkgdir}/usr/bin/titlecase" "${pkgdir}/usr/bin/titlecase-py2"
+}