summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMitch Bigelow2015-06-13 00:41:46 -0400
committerMitch Bigelow2015-06-13 00:41:46 -0400
commitb68479b3e87f8dec3be346117e7ac1cd365a8f36 (patch)
treec97571f061e628cb5fbe1a273ba15ca8048fc407 /PKGBUILD
downloadaur-python2-tornadio2.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36567eb30016
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mitch Bigelow <ipha00@gmail.com>
+
+pkgname=python2-tornadio2
+_realname=TornadIO2
+pkgver=0.0.4
+pkgrel=1
+pkgdesc='Socket.io server implementation on top of Tornado'
+arch=('any')
+url='http://github.com/MrJoes/tornadio2'
+license=('APACHE')
+depends=('python2' 'python2-distribute' 'python2-tornado')
+source=("https://pypi.python.org/packages/source/T/TornadIO2/TornadIO2-0.0.4.tar.gz")
+md5sums=('e500878c082746aa436116c88b3a1cdb')
+
+build() {
+ cd "$srcdir/TornadIO2-$pkgver"
+ python2 setup.py build
+}
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+} \ No newline at end of file