summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitf34c94fc9db0c74e5ee33189886e0ff9fa2b808e (patch)
treeabf1b8d69e61d7f27a438c4edf12a7bb0ee1ef6e /PKGBUILD
downloadaur-python2-utilitybelt.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a162496b3df5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-utilitybelt
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="Miscellaneous Python utilities"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://github.com/onenameio/utilitybelt"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/u/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('0dcb26400774975a6fdd65e3b13b9bb3')
+sha256sums=('dafdb6a2dbb32e71d67a9cd35afd7c2e4993ec094e7ddb547df4cf46788770a4')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}