summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabien Devaux2015-07-15 10:19:17 +0200
committerFabien Devaux2015-07-15 10:19:17 +0200
commit249b7c7f51f2b050a4c51ae104e6ce83db01a856 (patch)
tree8ede17bc4872e6c2f9793b8c92eaa02056e1f06a /PKGBUILD
downloadaur-python2-worm.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e3438d329b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: Fabien Devaux <fdev31 at gmail dot com>
+
+_py=python2
+_n=worm
+
+pkgname=$_py-$_n
+pkgver=0.3
+pkgrel=1
+pkgdesc="Animating worms for progress bars"
+depends=($_py)
+makedepends=($_py "$_py-distribute" "sed")
+arch=('any')
+source=(http://pypi.python.org/packages/source/${_n:0:1}/$_n/$_n-$pkgver.tar.gz)
+md5sums=(b8f250f3edea5ee842a08c88acadaef8)
+url="http://mechanicalcat.net/richard/"
+license="PUBLIC"
+
+build() {
+ cd $srcdir/$_n-$pkgver
+ sed -i 's/data_files/#data_files/' setup.py
+ $_py setup.py build || return 1
+ $_py setup.py install --root=$pkgdir
+}
+