summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Kluger2017-05-26 15:17:35 -0400
committerAndy Kluger2017-05-26 15:17:35 -0400
commit0238583a5d107dd1d389e93ca355e98013b86561 (patch)
treecd5b114f2db945f6f21665739613e649826e1caf /PKGBUILD
downloadaur-python2-x11_hash.tar.gz
py2 x11_hash for dash
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7eec710da935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+
+_pkgname=x11_hash
+pkgname=python2-${_pkgname}
+pkgver=1.4
+pkgrel=1
+pkgdesc="Binding for Dash's X11 proof of work hashing."
+arch=(any)
+url="https://github.com/mazaclub/x11_hash"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://github.com/mazaclub/x11_hash/archive/${pkgver}.tar.gz")
+
+package(){
+ cd ${_pkgname}-${pkgver}
+ python2 setup.py install --root="$pkgdir"
+}
+
+md5sums=('aeb83b7e868f504890a6a8d12c9ef2a0')