summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Manner2023-01-01 18:55:59 +0100
committerRobert Manner2023-01-01 18:56:47 +0100
commit070039a7fe36508e91707d9aa4a10dac821f2e32 (patch)
tree0fd4e11d0d176635146d54af1d0c706a7c5a1b8d /PKGBUILD
parentfdc49c19872687e6bd45c228846af925afc74a15 (diff)
downloadaur-pytranscriber-bin.tar.gz
update to 1.9
Also adds desktop file and icon, therefor using the "installer" zip as the source. (Portable does not have them.)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dc3c8e6c07b..8d66f8ac2767 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Robert Manner <the_manni at users.sf.net>
pkgname=pytranscriber-bin
-pkgver=1.8
+pkgver=1.9
pkgrel=1
pkgdesc="UI for generating transcription (subtitles) using Google Speech Recognition (X11)"
arch=('x86_64')
@@ -11,10 +11,17 @@ options=(!strip !zipman)
groups=()
depends=(libgl)
optdepends=()
-source=("${url}/releases/download/v${pkgver}-stable/pyTranscriber-v${pkgver}-linux-portable.zip")
-sha256sums=('a360e64ac95d8f99750d3b18d5afdeb6f9ad0c141d2be022c56597735152cd9d')
+conflicts=(pytranscriber-wl-bin)
+replaces=(pytranscriber-wl-bin)
+source=("${url}/releases/download/v${pkgver}/pyTranscriber-v${pkgver}-linux-installer.zip")
+sha256sums=('29f0ec7ad46b0f6328258cad8ce4ce977842f73ca2e98e3bc92b9cc37b661ded')
package()
{
- install -m 755 -D -T pyTranscriber-v${pkgver}-linux-portable/pyTranscriber-v${pkgver} "${pkgdir}/usr/bin/pyTranscriber"
+ install -m 755 -D -T pyTranscriber-v${pkgver}-linux-*installer/app/pyTranscriber "${pkgdir}/usr/bin/pyTranscriber"
+ install -m 644 -D -T pyTranscriber-v${pkgver}-linux-*installer/app/icon.png "${pkgdir}/usr/share/pyTranscriber/icon.png"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ sed -e 's:/opt/pyTranscriber/pyTranscriber:/usr/bin/pyTranscriber:' \
+ -e 's:/opt/pyTranscriber/icon.png:/usr/share/pyTranscriber/icon.png:' \
+ pyTranscriber-v${pkgver}-linux-*installer/shortcut/pytranscriber.desktop >"${pkgdir}/usr/share/applications/pytranscriber.desktop"
}