summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmish2025-01-19 12:46:53 +0530
committerAmish2025-01-19 12:46:53 +0530
commit1e46c441475677e1c8af25a36704ea5cce5dc00d (patch)
tree9decbc439a4ded07fbf9f0bed80458b66f5c466b /PKGBUILD
parent3ac2e18e19e67f0db6fed5e6b4d7b086b3afaaf2 (diff)
downloadaur-pyzor.tar.gz
Update to latest github commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 771477f11b62..f44cfceb8cd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# Maintainer: John Lane <archlinux at jelmail dot com>
+# Maintainer: Amish <contact at via dot aur>
+# Contributor: John Lane <archlinux at jelmail dot com>
# Contributor: Rich Li <rich@dranek.com>
-
pkgname=pyzor
-pkgver=1.0.0
-pkgrel=2
-pkgdesc="Detect and block spam using identifying digests of messages."
+pkgver=1.1.3b
+pkgrel=1
+_gitrev=0c44c6f
+pkgdesc='Spam-blocking networked system that uses spam signatures to identify spam'
arch=('any')
-url="https://github.com/SpamExperts/pyzor"
+url='https://github.com/SpamExperts/pyzor'
license=('GPL')
makedepends=('python-setuptools')
depends=('python')
-#source=(https://pypi.python.org/packages/source/p/pyzor/${pkgname}-${pkgver}.tar.gz)
-source=(https://files.pythonhosted.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('10ea114bdee2eee5edd6afe8eeddaaf605620445977ae019a3e9b1cbb6bc3b27')
+source=("${pkgname}-${pkgver}-${_gitrev}.tar.gz::https://github.com/SpamExperts/${pkgname}/archive/${_gitrev}.tar.gz")
+sha256sums=('3ccaa0827684e83ea708bab096dee2e76fa291ac954ea4275535025ac13a8d8c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${_gitrev}"*
+ python setup.py build
+}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "${srcdir}/${pkgname}-${_gitrev}"*
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}