summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Wucher2016-03-12 15:10:38 +0100
committerThomas Wucher2016-03-12 15:15:24 +0100
commit745b87e51f7db970ecf71d3ba1d0d2ac2f598054 (patch)
treee12a86c7c1c42f82b3bab8a611e27491b4f22836 /PKGBUILD
downloadaur-qhttpserver.tar.gz
Initial version
There are currently no official releases so this uses the git master branch until the first stable release is available.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54c13d3fb3ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Thomas Wucher <arch@thomaswucher.de>
+pkgname=qhttpserver
+pkgver=r134.ca8f327
+pkgrel=1
+pkgdesc="A Qt HTTP Server - because hard-core programmers write web-apps in C++ :)"
+arch=('i686' 'x86_64' 'arm6h' 'arm7h')
+url="https://github.com/nikhilm/qhttpserver"
+license=('custom')
+groups=()
+depends=(qt5-base)
+makedepends=('git')
+replaces=()
+backup=()
+options=()
+install=
+source=('qhttpserver::git+https://github.com/nikhilm/qhttpserver.git')
+noextract=()
+md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ mkdir -p "$pkgdir/usr/include"
+ cp src/*.h "$pkgdir/usr/include/"
+ cp -r lib "$pkgdir/usr/"
+}