summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-03-02 02:00:55 +0000
committerxiota2024-03-02 02:00:55 +0000
commit2f29b741f2c441e22f7eeda8628f4c1ad817685b (patch)
tree237907966518d30c41efcaa9a077fbd593b536bb /PKGBUILD
parentdd011f73036750e682dd4d4c939d888d40b5617c (diff)
downloadaur-qomui.tar.gz
Update to PEP 517
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD53
1 files changed, 39 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1aed7e59ed81..2b399fbd2c64 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,52 @@
+# Maintainer:
# Contributor: corrad1nho <corrado@posteo.net>
pkgname=qomui
pkgver=0.8.2
-pkgrel=2
-pkgdesc="OpenVPN Gui with advanced features and support for multiple providers"
-arch=("x86_64")
+pkgrel=3
+pkgdesc="Qt OpenVPN Management UI"
url="https://github.com/corrad1nho/qomui"
-license=("GPL3")
-depends=(python python-pyqt5 python-dbus openvpn stunnel bind-tools dnsmasq geoip python-psutil python-requests python-lxml python-beautifulsoup4 python-pexpect libcgroup wireguard-tools python-cryptography)
-makedepends=(python-setuptools)
-install=qomui.install
+license=("GPL-3.0-or-later")
+arch=("x86_64")
+
+depends=(
+ 'bind-tools'
+ 'openvpn'
+ 'python-beautifulsoup4'
+ 'python-cryptography'
+ 'python-dbus'
+ 'python-lxml'
+ 'python-pexpect'
+ 'python-psutil'
+ 'python-pyqt5'
+ 'python-requests'
+ 'stunnel'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+optdepends=(
+ 'dnsmasq: bypass OpenVPN'
+ 'geoip: identify server locations'
+ 'libcgroup: bypass OpenVPN'
+ 'openresolv: wireguard'
+ 'wireguard-tools: wireguard'
+)
+
+_pkgsrc="$pkgname-$pkgver"
source=("https://github.com/corrad1nho/qomui/archive/v$pkgver.tar.gz")
sha256sums=("78187864a4368fed06f6e58c4d411053a1d1193d625ee79be0a57bf0938b1d0b")
build() {
- cd "$pkgname-$pkgver"
- python setup.py build
+ cd "$_pkgsrc"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
- echo -e "$pkgver\nAUR" > $pkgdir/usr/share/qomui/VERSION
+ cd "$_pkgsrc"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-
-