summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiachen Yang2017-01-30 16:51:28 +0900
committerJiachen Yang2017-01-30 16:51:28 +0900
commit70e5ef899c189292b67599e269df2657e5d38a1e (patch)
treee14ec0216c926fec154bf136bb8ad5c943e5f448 /PKGBUILD
parent3b9b050ed48da95b85ca6a1fff35cb4642d7b661 (diff)
downloadaur-qsanguoshav2-git.tar.gz
fix build error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index decb2519dffc..62c29c668c53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=qsanguoshav2-git
_gitname=QSanguosha-v2
-pkgver=6017.bc669c2
-pkgrel=8
+pkgver=6046.142064ec
+pkgrel=1
pkgdesc="An open source online version of the famous board game Sanguosha"
arch=('i686' 'x86_64')
url="https://github.com/Mogara/QSanguosha-v2"
@@ -29,6 +29,10 @@ pkgver() {
build() {
cd ${srcdir}/${_gitname}
+
+ sed -i "s|if (AI::GetRelation3v3(player, judge->who) != AI::Friend) return false;|if (AI::GetRelation3v3(player, judge->who) != AI::Friend) return NULL;|" src/package/special3v3.cpp
+ sed -i "s|<fmod\.hpp>|<fmodex/fmod.hpp>|" src/pch.h
+ sed -i "s|for (int i = 0; roles\\[i\\] != '\\\0'; i++) |for (int i = 0; roles\\[i\\] != QChar('\\\0'); i++) |" src/core/engine.cpp
qmake-qt5 .
make
}