aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2016-06-08 16:16:05 -0700
committerDonald Carr2016-06-13 20:29:31 -0700
commit1cc24d22bc8af7e8c618db2965046ffe0cec0045 (patch)
treea1fa52a32c39bc1d1ae3d51ea484f3f69dd288cd /PKGBUILD
parent1d5efcdd82cca7ca65f178172021a24940a0b2b0 (diff)
downloadaur-1cc24d22bc8af7e8c618db2965046ffe0cec0045.tar.gz
Move away from namespacing
Adjust to VC4 DRM support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7b417fb88f2..e820d17dcf21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,18 @@ _static_build=false
_build_from_head=false
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
-pkgrel=10
+pkgrel=12
# 1 or 2 at present
_piver=""
+if [[ -z $_piver ]] && [[ -n $LOCAL_PI_VER ]]; then
+ _piver=$LOCAL_PI_VER
+fi
+
+if [[ -f testing ]]; then
+ _skip_web_engine=true
+fi
+
_pkgvermajmin="5.7"
pkgver="${_pkgvermajmin}.0"
@@ -80,19 +88,12 @@ _device_configure_flags=""
#Sanity check
__pkgconfigpath="${_sysroot}/usr/lib/pkgconfig"
-__eglpkgconfigpath="${__pkgconfigpath}/egl.pc"
-__glespkgconfigpath="${__pkgconfigpath}/glesv2.pc"
if [[ ! -d ${__pkgconfigpath} ]]; then
echo "You have to set a valid sysroot to proceed with the build"
exit 1
fi
-if [[ -f ${__eglpkgconfigpath} ]] || [[ -f ${__glespkgconfigpath} ]] ; then
- echo "Mesa is about to eat our communal poodle; delete egl.pc and glesv2.pc in your sysroot"
- exit 1
-fi
-
#end sanity check
# callbacks
@@ -177,6 +178,9 @@ fi
mkdir -p ${_bindir}
cd ${_bindir}
+ # Just because you can enable something doesnt mean you should
+ # Prepare for breakage in all your Qt derived projects
+ #-qtnamespace "Pi${_piver}" \
${_srcdir}/configure \
-no-icu \
-v \
@@ -185,7 +189,6 @@ fi
-silent \
-confirm-license \
-opensource \
- -qtnamespace "Pi${_piver}" \
-qtlibinfix "Pi${_piver}" \
-reduce-exports \
-reduce-relocations \