aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2019-02-09 10:33:38 -0800
committerDonald Carr2019-02-09 10:58:23 -0800
commit264e8c83b9b547526d19acbc7dc409bb350be174 (patch)
tree3e47af3dc68f20593104ab9a3fabdd9b8e96ce64 /PKGBUILD
parent53805dc3f0debfbbb5308f496974d2e4d5b1f005 (diff)
downloadaur-264e8c83b9b547526d19acbc7dc409bb350be174.tar.gz
Grovel at the feet of Qt 5.12.1 some more
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3088adfba133..60ef96244245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -480,7 +480,7 @@ package() {
# attempt to fix Qt 5.12.1's insane complete qualification of linked libraries
# this still results in other sources of the complete path
- find ${_installed_dir}/${pkgname}/mkspecs -type f | xargs sed -i "s,${_sysroot}[^ ]*lib\(.*\).so,-l\1,g"
+ find ${_installed_dir}/${pkgname} -type f -regex '.*\(prl\|pc\|pri\)' | xargs sed -i "s,/mnt/pi4/[^ ]*lib\(.[^ ]*\)\.so,-l\1,g"
# this breaks stuff as gcc does not look inside of sysroots for supposedly qualified paths
#find ${_installed_dir}/${pkgname}/mkspecs/modules -type f | xargs sed -i "s,${_sysroot}\([^ ]*\.so\),\1,g"