aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2017-09-21 23:07:22 -0700
committerDonald Carr2017-09-22 01:50:58 -0700
commit51208c5d34074ec4bd65e90cca947d299717df35 (patch)
tree7dfc6a4302e24b20ec82c4ca21ca3e6fddedb1d8 /PKGBUILD
parent438bb73b058ddec2cfb9a59620398b0cee1b7e4c (diff)
downloadaur-51208c5d34074ec4bd65e90cca947d299717df35.tar.gz
Start to track minimal QML friendly static configuration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 67 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e311277f77f..78bcffe7162b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -183,6 +183,7 @@ _installprefix=${_baseprefix}/${pkgname}
if $_static_build; then
_additional_configure_flags="$_additional_configure_flags
+ -ltcg \
-no-ico \
-no-glib \
-no-fontconfig \
@@ -217,12 +218,73 @@ _arch_specific_configure_options="\
-datadir /usr/share/qt \
-sysconfdir /etc/xdg \
-examplesdir /usr/share/doc/qt/examples \
- -no-rpath"
+ -no-rpath \
+"
+
+#-no-xcb \
+_exhaustive_static_specific_configure_options="\
+ -no-direct2d \
+ -no-directfb \
+ -no-eglfs \
+ -no-gbm \
+ -no-kms \
+ -no-linuxfb \
+ -no-mirclient \
+ -no-cups \
+ -no-iconv \
+ -no-accessibility \
+ -no-gif \
+ -skip qtconnectivity \
+ -skip qtlocation \
+ -skip qtremoteobjects \
+ -skip qtsvg \
+ -skip qtwebglplugin \
+ -skip qt3d \
+ -skip qtdatavis3d \
+ -skip qtmacextras
+ -skip qtscript \
+ -skip qttools \
+ -skip qtwebsockets \
+ -skip qtactiveqt
+ -skip qtmultimedia \
+ -skip qtscxml \
+ -skip qttranslations \
+ -skip qtwebview \
+ -skip qtandroidextras \
+ -skip qtdoc \
+ -skip qtnetworkauth \
+ -skip qtsensors \
+ -skip qtvirtualkeyboard \
+ -skip qtwinextras \
+ -skip qtgamepad \
+ -skip qtpurchasing
+ -skip qtserialbus \
+ -skip qtwayland \
+ -skip qtx11extras \
+ -skip qtcanvas3d \
+ -skip qtgraphicaleffects \
+ -skip qtquickcontrols \
+ -skip qtserialport \
+ -skip qtwebchannel \
+ -skip qtcharts \
+ -skip qtimageformats \
+ -skip qtquickcontrols2 \
+ -skip qtspeech \
+ -skip qtwebengine \
+ -no-sql-mysql \
+ -no-sql-psql \
+ -no-qml-debug \
+ -no-tslib \
+ -no-feature-bearermanagement \
+"
+
+if $_static_build; then
+ _additional_configure_flags="$_additional_configure_flags $_exhaustive_static_specific_configure_options"
+fi
# Seems to be creating a large amount of breakage
_core_configure_options="\
-prefix ${_installprefix} \
- -optimized-tools \
-optimized-qmake \
-optimize-size \
-confirm-license \
@@ -235,10 +297,11 @@ _core_configure_options="\
-egl \
-journald \
-make libs \
- -ltcg \
+ -nomake tools \
\
-reduce-exports"
+#-optimized-tools \
if ! $_testing; then
_core_configure_options="\
$_core_configure_options \
@@ -393,6 +456,7 @@ else
-device ${_mkspec} \
-device-option CROSS_COMPILE=/opt/${_toolchain_name}/bin/${_toolchain_name}- \
-no-xcb \
+ -qpa eglfs \
${_additional_configure_flags}"
fi
local _configure_line_fn=configure_line