summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2024-09-03 23:24:41 +0200
committerFabioLolix2024-09-03 23:24:41 +0200
commit49396298098508275eff300fddf5c42207069db9 (patch)
tree4972743db78d8bfbe3042b7d3b0b8242adf997cd /PKGBUILD
parente2169d6aa789485208a0c4ee199d11c416aa5d87 (diff)
downloadaur-qt5-webkit-git.tar.gz
switch source+ruby patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb772a924380..8d5a0490a7cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,12 @@
# Contributor: Dāvis Mosāns <davispuh at gmail dot com>
pkgname=qt5-webkit-git
-pkgver=5.212.0.alpha4.r13.gac8ebc6c3
-pkgrel=4
+pkgver=5.212.0.alpha4.r188.g756e1c8f23dc
+pkgrel=2
arch=(x86_64)
url='https://github.com/qtwebkit/qtwebkit'
license=(LGPL2.1)
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
-source=("qt5-webkit::git+https://code.qt.io/qt/qtwebkit.git#branch=5.212"
- "https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/qtwebkit-cstdint.patch"
- icu68.patch
- glib-2.68.patch
- "https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/qtwebkit-fix-build-gcc14.patch")
depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxcomposite gst-plugins-base hyphen woff2
# namcap implicit depends
@@ -20,44 +15,48 @@ depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxcomposite gst-plugi
qt5-base qt5-declarative)
# libxslt
depends+=(libicuuc.so libicui18n.so)
-makedepends=(git cmake ruby gperf python qt5-doc qt5-tools)
+makedepends=(git cmake ruby ruby-erb gperf python qt5-doc qt5-tools)
optdepends=('gst-plugins-good: Webm codec support')
provides=(qt5-webkit)
conflicts=(qt5-webkit)
options=(!lto)
+source=("git+https://github.com/qtwebkit/qtwebkit.git#branch=qtwebkit-5.212"
+ "https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/qtwebkit-fix-build-gcc14.patch"
+ https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/webkit-offlineasm-warnings-ruby27.patch)
sha256sums=('SKIP'
- '4c71c958eae45cae65c9f002024eb1369d06029b668e595158138ff7971e64f1'
- '0b40ed924f03ff6081af610bb0ee01560b7bd1fb68f8af02053304a01d4ccdf0'
- '4969dd03e482155e2490b50307dada81dda7bbc9e5398e3a53c20bc474f7c04e'
- 'eea38db22078700887bf22b6a49bb628fd8444cdb2e506770c993df883d0e8fb')
+ 'eea38db22078700887bf22b6a49bb628fd8444cdb2e506770c993df883d0e8fb'
+ '8768433ff3f641b506962ed22cc596eaf57bf21b6d3402e0e73ad8c2afeaa502')
pkgver() {
- cd "$srcdir/qt5-webkit"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "qtwebkit"
+ # Tag on 10/03
+ git tag -f qtwebkit-5.212.0.alpha4 874098cc94c9dda3ae5dc5cbe49a447685216bea
+ git describe --long --tags | sed 's/^qtwebkit-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/qt5-webkit"
- patch -p0 -i ../icu68.patch # Fix build with ICU 68.x
- patch -p1 -i ../glib-2.68.patch # https://github.com/qtwebkit/qtwebkit/issues/1057
- patch -p1 -i ../qtwebkit-cstdint.patch # gcc 11.1
- patch -p1 -i ../qtwebkit-fix-build-gcc14.patch # GCC 14.1
+ cd "qtwebkit"
+ patch -p1 -i ../qtwebkit-fix-build-gcc14.patch
+ echo "Done patch for GCC 14.1"
+
+ patch -Np1 -i ../webkit-offlineasm-warnings-ruby27.patch
+ echo "Done patch for Ruby 3.2"
}
build() {
- cmake -B build -S qt5-webkit -Wno-dev \
+ cmake -B build -S qtwebkit -Wno-dev \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG" \
+ -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python \
-DPORT=Qt \
-DUSE_LD_GOLD=OFF \
-DENABLE_XSLT=OFF \
-DENABLE_TOOLS=OFF
+
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
-
- install -d "$pkgdir"/usr/share/licenses
- ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
}