summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Barany2019-07-27 16:41:23 -0700
committerAaron Barany2019-07-27 16:42:34 -0700
commitf3f07e0788a5f89727f8fc988656f0abf325c5a4 (patch)
tree5d772bbd27b63255f5e2c43d58643d0e0b0313c0 /PKGBUILD
parentdb4191e8398af97de44d7cb87f0e60cb5e1643c6 (diff)
downloadaur-qtcreator-fixed-themes.tar.gz
Updated to 4.9.2 with latest clang.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79f9b7428fbe..4190aceba3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@
# Contributor: delor <bartekpiech gmail com>
pkgname=qtcreator-fixed-themes
-pkgver=4.9.1
-_clangver=8.0.0
-pkgrel=1
+pkgver=4.9.2
+_clangver=8.0.1
+pkgrel=3
pkgdesc='Lightweight, cross-platform integrated development environment, with theme and bug fixes applied'
arch=(x86_64)
url='https://www.qt.io'
@@ -30,14 +30,17 @@ optdepends=('qt5-doc: integrated Qt documentation'
'git: git support'
'mercurial: mercurial support'
'bzr: bazaar support'
- 'valgrind: analyze support')
+ 'valgrind: analyze support'
+ 'perf: performer analyzer')
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
qtcreator-clazy-1.5.patch
qtcreator-preload-plugins.patch
+ qtcreator-mime-database.patch
qtcreator-debugger-layout.patch)
-sha256sums=('79b8228d0871927837681e6af9ab91e3ea28154cecfba317f9c0e56246b8ad81'
+sha256sums=('b7e0c797e7704c6c22eb35351946c0a758502fd082f6beaee043166e1739d3d7'
'1f6998fea92b9a157f42cca783839ce95f70ccc667027078b7881cbb253838f0'
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d'
+ '8d64b5c28535dcaab910f32e82b04b425253015ca70f379cbe5e9693526a852a'
'6000452635f8c8f0cd21d1cc8d484821f4d0f8fc36afa744de5c2a3fdd1a5e9c')
prepare() {
@@ -55,6 +58,7 @@ prepare() {
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
# and https://bugs.archlinux.org/task/59492
patch -p1 -i ../qtcreator-preload-plugins.patch
+ patch -p1 -i ../qtcreator-mime-database.patch # Use system shared-mime-info
# Fixes for debugger layout.
patch -p1 -i ../qtcreator-debugger-layout.patch
}