summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2024-05-01 20:31:38 +0200
committerFabioLolix2024-05-01 20:31:38 +0200
commit54c7965d52408528384d5df06495c43833c542b5 (patch)
tree67700799ae28abe691959855c5298a977730849a /PKGBUILD
parent301d5a8677ca66c96250fa9e68d64b639f69cd77 (diff)
downloadaur-quickemu-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 21 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42831c54dcec..6e3ec8bcfb98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,36 @@
pkgname=quickemu-git
pkgver=4.9.2.r468.gfaee282
-pkgrel=1
-pkgdesc='Quickly create and run optimised Windows, macOS and Linux desktop virtual machines'
-arch=('any')
-url="https://github.com/${pkgname%-git}-project/${pkgname%-git}"
-license=('MIT')
-depends=('qemu' 'jq' 'python3' 'cdrtools' 'usbutils' 'spice-gtk' 'swtpm' 'wget' 'xorg-xrandr' 'zsync' 'edk2-ovmf')
-makedepends=('git')
+pkgrel=2
+pkgdesc="Quickly create and run optimised Windows, macOS and Linux desktop virtual machines"
+arch=(any)
+url="https://github.com/quickemu-project/quickemu"
+license=(MIT)
+depends=(qemu jq python3 cdrtools usbutils spice-gtk swtpm wget xorg-xrandr zsync edk2-ovmf)
+makedepends=(git)
optdepends=('quickgui: graphical user interface'
'aria2: faster downloads')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
-source=("git+$url")
+provides=(quickemu)
+conflicts=(quickemu)
+source=("git+$url.git")
b2sums=('SKIP')
pkgver() {
- cd ${pkgname%-git}
+ cd "quickemu"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd ${pkgname%-git}
- install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/${pkgname}
- install -Dm755 quickemu -t "$pkgdir"/usr/bin
- install -Dm755 quickget -t "$pkgdir"/usr/bin
- #install -Dm755 macrecovery -t "$pkgdir"/usr/bin
+ cd "quickemu"
+ install -Dm755 quickemu -t "${pkgdir}/usr/bin"
+ install -Dm755 quickget -t "${pkgdir}/usr/bin"
+ install -Dm755 chunkcheck -t "${pkgdir}/usr/bin"
+ install -Dm755 windowskey -t "${pkgdir}/usr/bin"
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
cd docs
- install -Dm644 quickget.1 -t "$pkgdir"/usr/share/man/man1
- install -Dm644 ${pkgname%-git}.1 -t "$pkgdir"/usr/share/man/man1
- install -Dm644 ${pkgname%-git}_conf.1 -t "$pkgdir"/usr/share/man/man1
+ install -Dm644 quickget.1 -t ${pkgdir}/usr/share/man/man1
+ install -Dm644 quickemu.1 -t ${pkgdir}/usr/share/man/man1
+ install -Dm644 quickemu_conf.1 -t ${pkgdir}/usr/share/man/man1
}