summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-03-22 20:32:28 +0100
committerhaawda2018-03-22 20:32:28 +0100
commit4a773ec6f3950a9011f436586a6df4c7c4f6a944 (patch)
treef0bdf7a052493766d7ede6df97ef36271e7ead0b /PKGBUILD
parentd126c25839ea679799df76475f53ba433ea742c9 (diff)
downloadaur-quotepas.tar.gz
make package ready for pacman 4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cd437d76e90..58965f5b6073 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=quotepas
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="LaTeX style that can be used to insert passages from a database."
url="http://theoval.cmp.uea.ac.uk/~nlct/latex/packages"
arch=('any')
license=('LPPL')
depends=('texlive-core' 'perl')
-source=(http://theoval.cmp.uea.ac.uk/~nlct/latex/packages/quotepas/$pkgname.tar.gz)
-md5sums=('0c31eb7a8f1a2fcac2aa48ebd5cac034')
-build() {
- cd $srcdir
+source=(http://theoval.cmp.uea.ac.uk/~nlct/latex/packages/$pkgname/$pkgname.tar.gz)
+md5sums=('ebb23d8759d140a87c4f42e20fc39e2d')
+
+package() {
for _i in README sample.tex $pkgname.pdf database.qup
do
- install -Dm644 ${_i} $pkgdir/usr/share/texmf/doc/$pkgname/${_i}
+ install -Dm644 ${_i} "$pkgdir"/usr/share/texmf/doc/$pkgname/${_i}
done
for _i in $pkgname.ins $pkgname.dtx
do
- install -Dm644 ${_i} $pkgdir/usr/share/texmf/tex/latex/$pkgname/${_i}
+ install -Dm644 ${_i} "$pkgdir"/usr/share/texmf/tex/latex/$pkgname/${_i}
done
- install -Dm755 $pkgname.pl $pkgdir/usr/bin/$pkgname
+ install -Dm755 $pkgname.pl "$pkgdir"/usr/bin/$pkgname
}