summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordatabase641282022-01-14 18:35:07 +0800
committerdatabase641282022-01-14 18:35:07 +0800
commitbc0321da77515fafa7ae59781c9b7c7408c7a98a (patch)
tree2faa6e56dbca632bd26813a8aed73b3a5f9602e7 /PKGBUILD
parenta126d5c74651754e9a280cdc889913f7b9a91123 (diff)
downloadaur-qv2ray-static-bin-nightly.tar.gz
🍥 Migration: Add qv2ray-static-nightly-bin as dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53e25579a052..4c8749c520bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,15 @@
# Maintainer: database64128 <free122448@hotmail.com>
pkgname=qv2ray-static-bin-nightly
-pkgver=20210822
+pkgver=20211215
pkgrel=1
pkgdesc="A cross platform connection manager for V2Ray and other backends"
arch=(x86_64)
url="https://github.com/Shadowsocks-NET/Qv2ray"
license=('GPL3')
-depends=('brotli' 'double-conversion' 'fontconfig' 'glibc' 'libb2' 'libcups' 'libgl' 'libinput'
- 'libjpeg-turbo' 'libproxy' 'libxi' 'libxkbcommon-x11' 'libxrender' 'mesa' 'shared-mime-info'
- 'tslib' 'xcb-util-cursor' 'xcb-util-keysyms' 'xcb-util-wm' 'xdg-utils')
+depends=('qv2ray-static-nightly-bin')
makedepends=('jq')
-optdepends=('v2ray: use packaged v2ray')
-provides=('qv2ray')
-conflicts=('qv2ray' 'xray')
release=$(curl -s https://api.github.com/repos/Shadowsocks-NET/QvStaticBuild/releases/latest)
pkgver() {
echo $release | jq -r '.tag_name' | sed 's/^nightly-//;s/-//g'
}
-
-package() {
- curl -Lo $pkgver.tar.zst $(echo $release | jq -r '.assets[0].browser_download_url')
- mkdir $pkgdir/usr
- tar -C $pkgdir/usr -xvf $pkgver.tar.zst
-}