summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrii Zymohliad2023-09-30 08:38:24 +0300
committerAndrii Zymohliad2023-09-30 08:38:24 +0300
commit72afc6a261c54da95a63294c2f8a9954a24730f0 (patch)
treeb81024ae77ea8335612603ba76161d4788360b70 /PKGBUILD
parent054c0d5a9b34e0ee2cacdf973768d3bcb6609671 (diff)
downloadaur-qwertone-git.tar.gz
Update pkgver() to strip "v" from the tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5676069b408e..9c0a72d61a8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Andrii Zymohliad <azymohliad@pm.me>
pkgname=qwertone-git
-pkgver=v0.1.1.r0.eb0a38a
+pkgver=0.4.0.r0.24bcfb0
pkgrel=1
pkgdesc='Turns your PC into musical instrument'
arch=(x86_64)
url='https://gitlab.com/azymohliad/qwertone'
license=('GPL')
depends=('gtk3' 'alsa-lib')
-makedepends=('git' 'cargo')
+makedepends=('git' 'cargo')
provides=('qwertone')
conflicts=('qwertone')
source=("$pkgname::git+https://gitlab.com/azymohliad/qwertone.git")
@@ -15,7 +15,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "%s" "$(git describe --long | sed 's/v//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {