summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-25 08:10:54 +0000
committerBioArchLinuxBot2024-04-25 08:10:54 +0000
commit4d48b552943818869f962c0bcd4d2a481e8fc905 (patch)
treeb9126eb77d3845a38e7b4df94811824874203cfe /PKGBUILD
parent5c712469f33de3eb31769b3ac8b67447fdcdcd5f (diff)
downloadaur-r-cachem.tar.gz
[lilac] updated to 1.0.8-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f117a5099507..1b91663e7869 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
_pkgname=cachem
_pkgver=1.0.8
pkgname=r-${_pkgname,,}
-pkgver=${_pkgver//[:-]/.}
-pkgrel=2
+pkgver=${_pkgver//-/.}
+pkgrel=3
pkgdesc="Cache R Objects with Automatic Pruning"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(MIT)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('MIT')
depends=(
r-fastmap
r-rlang
@@ -23,11 +23,11 @@ optdepends=(
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
md5sums=('f7b8c1dae009101e6785febca66bb659')
-sha256sums=('ea9ca919fe615dce8770758ecc2fc88ac99074f66ff1cde3a0b95d40007f45c2')
+b2sums=('0d575f66233a207c464842807d7a34a05c1e458c09588eb900ab9b28e68652229be55924f71f581100aefff9ae3e36ccefe0d5cfa37045dc89b035e555475e3c')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {