summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-08 18:04:31 +0000
committerBioArchLinuxBot2024-02-08 18:04:31 +0000
commit2f5ddfb81bcc95769364e67519a2a5e730ec12e7 (patch)
tree4880f116e759dbadd68f822cde36a8fe40058005 /PKGBUILD
parenta7e10cd2e4f8a23c57a8884d315f7bd850578c4c (diff)
downloadaur-r-compquadform.tar.gz
[lilac] updated to 1.4.3-11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34bd8bdf43bc..7e150cdb74fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,25 @@
_pkgname=CompQuadForm
_pkgver=1.4.3
pkgname=r-${_pkgname,,}
-pkgver=1.4.3
-pkgrel=9
-pkgdesc='Distribution Function of Quadratic Forms in Normal Variables'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=11
+pkgdesc="Distribution Function of Quadratic Forms in Normal Variables"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
r
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('042fc56c800dd8f5f47a017e2efa832caf74f0602824abf7099898d9708660c4')
+md5sums=('e4cb74a3022e0653b46881ac7bc024fd')
+b2sums=('48b46b02020032ca131b6f52a7555a6858ba30fb86c21842e3eda75757e8df886c0f88ca784bc53d50dbf4acfa581ac7618c1342d6fc10efba14122e80652eb9')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: