summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-01-24 18:07:08 +0000
committerBioArchLinuxBot2024-01-24 18:07:08 +0000
commit6c9395db731b83403a486c2935df08dd76b6e36e (patch)
tree527f0b31d938d5f41ec5f7f8ba09d2768a5d5e93 /PKGBUILD
parent40073c89b36f5b52eb0bbf91e75c54245810e651 (diff)
downloadaur-r-consrank.tar.gz
[lilac] updated to 2.1.4-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5f6219c950e..027cb6ed16d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
_pkgname=ConsRank
-_pkgver=2.1.3
+_pkgver=2.1.4
pkgname=r-${_pkgname,,}
-pkgver=${_pkgver//[:-]/.}
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Compute the Median Ranking(s) According to the Kemeny's Axiomatic Approach"
arch=(any)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(GPL3)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
r-gtools
r-proxy
@@ -17,12 +17,12 @@ depends=(
r-tidyr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('b24aef924d7c79a5006eff16c1dc968b')
-sha256sums=('7ef9fd405d2f01a9b31fccbbfe0bdb1fd3dcbec6654f553db3ef3a21ffc92d6c')
+md5sums=('eaa7f5278805dd3564a6bd4ed414fcc9')
+b2sums=('df7a1570f27167a9bb94abfb6ed40dda53c2f5a06f0e91a5fa19803070257f0afa0ed7ba96d04716993ef35ccc3848e84c62c212045097d64c24a8a6c17bc168')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {