summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-07 00:02:36 +0000
committerBioArchLinuxBot2024-03-07 00:02:36 +0000
commit35fac86b095323ad0bf1587bb1c47fb17cd23cce (patch)
treec7be6b21045ccfac5bf8812d8184ffff9efb3900 /PKGBUILD
parent78881772d2b944d8c7e8ba22b2a51890c135332c (diff)
downloadaur-r-fmstable.tar.gz
[lilac] updated to 0.1.4-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8167200734ee..7d6a1a517e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,25 @@
_pkgname=FMStable
_pkgver=0.1-4
pkgname=r-${_pkgname,,}
-pkgver=0.1.4
-pkgrel=2
-pkgdesc='Finite Moment Stable Distributions'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=4
+pkgdesc="Finite Moment Stable Distributions"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
r
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('2a391061dc2d2e89f6639aada07e839fdf950c0b20e27566219bb89befb4e93a')
+md5sums=('3697fa5f8c5cc6acfcf0285ca7819f56')
+b2sums=('f28d9b17352e3d6c0ad287512e9b08af46aafff97b5ca5287ad32f472a3a07a6586982a1ec3d93bd9bba030943880c105d9eb18df33904b4a65db97bf37844a0')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: