summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 10:08:31 +0800
committerSukanka2022-06-06 10:08:31 +0800
commit3a5092a83a96878aac70470d8438a8129357d36c (patch)
treeebfff48d77ad6097b036422cbce6be9eb16e9af0 /PKGBUILD
downloadaur-r-freqprof.tar.gz
add r-freqprof
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cb59f68c752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=FreqProf
+_pkgver=0.0.1
+pkgname=r-${_pkgname,,}
+pkgver=0.0.1
+pkgrel=4
+pkgdesc='Frequency Profiles Computing and Plotting'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ggplot2
+ r-reshape2
+ r-shiny
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a409b4e24b302e9aa9d41833f4935177639f7606aad6b299834f0b5a061116fb')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: